搬码资源网广告位 搬码资源网广告位

WordPress后台更新插件主题时提示输入FTP信息的解决方法

当你在Linux系统的VPS上安装完LAMP或者LNMP之后,总是会用root用户转移数据文件,然后问题就出现了。在你使用wordpress登录后台需要更新插件或者是下载主题时,总是会提示你要输入FTP帐号和密码之类的信息,如下

这是由于你使用root用户转移文件后,文件的所有者和所在组就都变成了root,而Apache和Nginx只有www用户的权限,所以无法写入及更改文件,这时就会要求你提供FTP认证信息了。

@R_403_323@很简单,将目录递归地设置所有者和所在组为www即可。假设目录为 /home/www/slyar.com ,具体命令如下

chown -R www /home/www/slyar.com

chgrp -R www /home/www/slyar.com

声明:
本站发布的文章及附件仅限用于学习和研究目的;不得将上述内容用于商业或非法用途,否则后果请用户自负。
本站资源来自网络收集,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。
如果您喜欢该程序,请支持正版软件,得到更好的正版服务。
本文链接:https://www.abnma.com/10212.html,转载请注明出处。
如有侵权,请邮件联系我们删除处理。

0
搬码资源网广告位

评论0

请先

没有账号? 注册  忘记密码?